Popüler web uygulama sunucusu olan Apache Tomcat üzerinde bulunan kritik güvenlik açığı (CVE-2017-12617) HTTP PUT metodu açık olan Tomcat sunucularda uzaktan komut çalıştırmaya imkan sağlamaktadır. Apache Tomcat sürümü 9.0.1 (Beta), 8.5.23, 8.0.47 ve 7.0.82 öncesi olanları etkileyen bu kritik zafiyetin giderilmesi için güncel versiyona geçiş yapılması gerekmektedir.

Envanterinizde bulunan Apache Tomcat sunucularınızın bu zafiyetten etkilenip etkilenmediğini https://github.com/cyberheartmi9/CVE-2017-12617 github adresinde bulunan python kodu ile test edebilirsiniz.

Demo

-Github adresinden ilgili projeyi indiriniz.

[[email protected]:~#] git clone https://github.com/cyberheartmi9/CVE-2017-12617

-Proje dizinine geçiniz.

[[email protected]:#] cd CVE-2017-12617/

-İlgili python kodunu çalıştırıp -u parametresi ile Tomcat sunucunuzun url bilgisi yazarak zafiyet barındırıp barındırmadığını görebilirsiniz. Zafiyet bulunması halinde “Poc.jsp” dosyası sunucunuza yüklenmiş olacaktır.

[[email protected]:~/CVE-2017-12617#] ./tomcat-cve-2017-12617.py -u http://172.16.44.10:8080

-Web tarayıcısından tomcat_sunucu/Poc.jsp dizinine gittiğinizde aşağıdaki gibi bir ekranla karşılaşmanız gerekmektedir. Bu ekrana ulaşıyorsanız bu Tomcat sunucunun vulnerable bir sunucu olduğu ve uzaktan komut çalıştırılabilir olduğu anlamına gelmektedir.

-Tomcat sunucusunda shell elde etmek için;

[[email protected]:~/CVE-2017-12617#] ./tomcat-cve-2017-12617.py -u http://172.16.44.10:8080 -p shell

Zafiyetten etkilenmemek için Tomcat güncellemelerinin en az aşağıdaki versiyonlardan daha üst versiyonlara güncellenmesi gerekmektedir. Ayrıca HTTP PUT metoduna ihtiyacınız bulunmuyorsa kapatılması faydalı olacaktır.

Apache Tomcat < 9.0.1 / < 8.5.23 / < 8.0.47 / < 7.0.8

 

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Time limit is exhausted. Please reload CAPTCHA.

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Post Navigation